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Foreword 

In this section the following information is included: 

• About this User Guide and Help 
• Terminology 
• Side Headings 
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About this User Guide and Help 
The Alt&Title user guide and Help provide detailed instruction about how 
to operate Alt&Title; from installation and configuration, to scanning and 
adding alt and title attributes to HTML tags, they are designed as an 
everyday reference for both beginners and experts. 

The user guide and Help assume you have a working knowledge of the 
Windows® operating system and its conventions, including how to use a 
mouse and keyboard, and how to run applications from the desktop or 
Start menu. For help with any of these techniques, please refer to your 
Windows® documentation or help. 

Printing 

The Alt&Title Help is primarily designed for on-screen reference. Even 
though its content can be printed, it is the Alt&Title user guide 
(AltTitle_User_Guide.pdf) that is better suited for this purpose. 

The layout of the user guide is designed for duplex (back to back) printing. 
If your printer has a duplex facility, please ensure it is set prior to printing. 
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Terminology 
Certain terms are underlined throughout the user guide and Help. By 
positioning your mouse pointer over one of these links and pressing your 
primary mouse button, one of the following actions occurs… 

• A pop-up description of the term is displayed alongside. 
• A page within the user guide or Help that describes the term or a 

topic relating to it is displayed. 
• A Fly Software web page relating to the term is displayed. 
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Side Headings 
For quick reference, the following side headings are displayed throughout 
the Alt&Title user guide and Help: 

EXAMPLE: 
Provides an example of the current topic. 

NOTE: 
Provides additional information or hints to assist in performing a task or 
understanding the current topic. 

MORE: 
Used to indicate where further details about the current or a related topic 
can be found. 

CAUTION: 
Used if the current action or omission may cause irretrievable results such 
as loss of data.
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Contents 

In this section the following information is included: 

• At a Glance 
• Concise 
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Introduction 

In this section the following information is included: 

• Why You Need Alt&Title 
• What Alt&Title can do for You 
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Why You Need Alt&Title 
As a web developer you already know certain HTML tags should contain 
alt and title attributes. Not only do they add visual cues and improve 
accessibility, they also help your web pages adhere to standards 
published by the World Wide Web Consortium (W3C). 

    

Fig. 1 Examples of alt and title attributes in use 

Despite their importance, have you (like many other developers) created 
web pages that contain HTML tags that do not contain an alt attribute or 
more likely a title attribute? 

The problem of missing title attributes has become conspicuous with the 
release of Internet Explorer 8 and the increased popularity of Firefox. 
Unlike earlier versions of Internet Explorer, these browsers do not use the 
alt attribute to display a tooltip for certain page elements. Instead, the title 
attribute is used for this important visual cue. 

If your website portfolio amounts to hundreds or thousands of pages, 
locating missing alt and title attributes and adding them to applicable 
HTML tags would be a very time consuming and costly process. 

To help you quickly and easily resolve this problem, Fly Software has 
developed Alt&Title. 



Introduction 

Alt&Title User Guide 3 

What Alt&Title can do for You 
Alt&Title scans web pages and reports which supported HTML tags have 
missing alt and title attributes.  

 

Fig. 2 Locating and reporting missing alt and title attributes 

More importantly, Alt&Title can automatically add a title attribute to a 
supported HTML tag if an alt attribute is already present, and vice versa. 

 

Fig. 3 Adding attributes 

For example, if a HTML tag already contained alt=”Buy Now!”, Alt&Title 
would automatically add title=”Buy Now!” to the same tag. Similarly, if 
title="Download Now!" was present, alt="Download Now!" would be 
added. 

Adding missing alt and title attributes to supported HTML tags is 
automatic, and can be performed on any number of web pages in 
seconds. 

All alt and title attribute additions are reported, so you know exactly 
which web pages and tags have been updated, and what attribute 
content has been applied. There is even a preview facility that allows you 
to see what changes will be made prior to updating associated web 
pages. 

By using Alt&Title, you no longer need to painstakingly open your web 
pages then locate and add missing alt and title attributes. Now you can 
simply select the problematic web pages, click a button and let Alt&Title 
perform the job for you! 
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Getting Started 

In this section the following information is included: 

• System Requirements 
• Supported File Formats 
• Supported HTML Tags 
• Installing 
• Launching 
• Workspace Overview 
• Licensing 
• Displaying Developer and Application Information 
• Viewing Preferences 
• Using Panels 
• Navigating Folders 
• Selecting Files 
• Updating 
• Shutting Down 
• Uninstalling 
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System Requirements 
Alt&Title has the following minimum computer system requirements: 

• Microsoft® Windows® 7, Vista, XP, 2003, 2000, NT.  
• Intel® Pentium® or AMD® K6 processor.  
• 128 MB of RAM (512 MB recommended).  
• 20 MB of available hard-disk space.  
• 800x600 pixel screen resolution.  
• Internet connection for licensing (recommended). 
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Supported File Formats 
Alt&Title supports the following default file formats: 

asa ascx asmx asp aspx cfc cfml dwt 

hta htc htm html inc php php3 php4 

php5 shtm shtml ssi stm xhtml   

 

If a file format you wish to scan or perform an add attribute process on is 
not included, you can specify your own. 

MORE: 
For further details about selecting and deselecting a file format and 
specifying your own, refer to Configuration > File Formats. 
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Supported HTML Tags 
Alt&Title supports the following HTML tags: 

• area 
• img 
• input (image)  

NOTE: 
The HTML Tag buttons contained on the Application toolbar and the 
options contained on the Tools menu determine which tags are 
processed. 

MORE: 
For further details about selecting HTML tags, refer to Configuration > 
HTML Tags. 
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Installing 
The Alt&Title installation file, AltTitle_Setup.exe, can be downloaded from 
the following Fly Software web page… 

http://www.flysoftware.com/downloads 

When the download is complete, double-click the file to start the 
installation procedure. Following this, the Installation Wizard is displayed 
which guides you through the entire Alt&Title installation. 

NOTE: 
Alt&Title can only be installed when you are logged on to Windows® as an 
administrator. 

NOTE: 
Installation can be aborted at anytime by clicking the Cancel button. 

Default Install Locations 

Alt&Title’s application files and application data are stored in different 
locations. 

Application Files 

By default, Alt&Title’s application files are installed in the following 
location: 

C:\Program Files\Fly Software\AltTitle\ 

Application Data 

By default, Alt&Title’s application data, including its configuration file 
App.ini, and licence file AltTitle.lic, are installed in the following location: 

Windows® XP, 2003, 2000, NT 

C:\Documents and Settings\All Users\Application Data\Fly 
Software\AltTitle 

Windows® 7, Vista 

C:\ProgramData\Fly Software\AltTitle\ 

NOTE: 
The Application Data and ProgramData folders may be hidden from view 
in Windows® Explorer or My Documents. 

http://www.flysoftware.com/downloads�
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MORE: 
To show the Application Data and ProgramData folders, refer to your 
Windows® documentation or Help. 
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Launching 
Launch Alt&Title by clicking the Alt&Title icon (Fig. 4) in the Fly Software 
folder on the Windows® Start Menu. Alternatively, double-click the 
Alt&Title icon on the Windows® desktop (if available). 

 

Fig. 4 Alt&Title icon 

Following launch, the application workspace (Fig. 5) is displayed. 
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Workspace Overview 
When Alt&Title is launched, the application window opens to display the 
workspace (Fig. 5).  

 

Fig. 5 Alt&Title workspace 

The following components are contained within the Workspace: 

 Name Description 

1 Title bar Displays the application icon and name, 
and buttons to resize and close the 
application window. 

2 Application menus 
(File, Tools, Log and Help) 

Provides access to Alt&Title functionality.  

3 Application toolbar Contains buttons that provide access to 
core Alt&Title functionality. 

4 Folder panel Provides access to the folders contained 
within the Windows® file system. 

5 File panel Displays the files contained within the 
folder selected in the Folder panel. 
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 Name Description 

6 Log panel Displays messages during a scan or add 
attribute process. 

7 References panel Displays references such as image 
filenames located during a scan or add 
attribute process. 

8 References Ignored panel Displays references such as image 
filenames that Alt&Title should ignore 
during a scan or add attribute process. 

9 Log toolbar Provides access to Log panel functionality 
and displays the progress bar.  

10 Progress bar Indicates the progress of a scan or add 
attribute process. 

11 Status bar Displays the tooltip of an application object 
the mouse pointer is currently hovering 
over. 
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Licensing 
Until Alt&Title is licensed, the functionality to add alt and title attributes is 
disabled. 

NOTE: 
The Preview button on the Application toolbar will remain pressed, and 
the Preview option on the Tools menu will remain ticked, all the while 
Alt&Title is unlicensed. As such, when an add attribute process is 
performed, only a preview is generated in the Log panel. 

Licensing Alt&Title is performed using an online or manual process.  

Purchasing a Licence 

An Alt&Title licence can be purchased from the following Fly Software 
web page: 

http://www.flysoftware.com/products/altandtitle/overview.asp 

Online Licensing 

Online licensing requires an Internet connection on the computer where 
Alt&Title is installed, and is the recommended and most convenient 
method of licensing. 

Select Help > Licensing to open the License dialog Online tab (Fig. 6) 
where Alt&Title can be licensed or unlicensed using the online method. 

http://www.flysoftware.com/products/altandtitle/overview.asp�
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Fig. 6 Licensing dialog Online tab 

Connecting to Your Fly Software User Account 

Prior to licensing Alt&Title online, you must connect to your Fly Software 
user account.  

In the Licensing dialog Online tab (Fig. 6) specify your user name and 
password then click the OK button. Following this, Alt&Title will attempt 
to connect to your user account on the Fly Software web server. If 
successful, Alt&Title is displayed together with its licence status (Yes and 
No), and the Available and Pending licences contained in your user 
account. 

NOTE: 
You are prompted to create a user account when you purchase an 
Alt&Title licence or any other Fly Software product for the first time. 
However, if you would like to create a user account prior to this visit the 
following Fly Software web page: 

http://www.flysoftware.com/user_access/register.asp 

NOTE: 
Pending licences indicate the quantity of Alt&Title licences purchased 
through the associated Fly Software user account but not yet paid for. 

http://www.flysoftware.com/user_access/register.asp�


Getting Started 

16 Alt&Title User Guide 

When payment is received by Fly Software, applicable Pending licences 
become Available licences which can be used to license Alt&Title. 

License 

To license Alt&Title you must have at least one Available licence. 

In the Licensing dialog Online tab (Fig. 6), click the License button. If 
successful, Yes is displayed in the Licensed column, and an Available 
licence for the associated plug-in is removed from your user account. 

NOTE: 
If Alt&Title was previously licensed (but had not been un-licensed) for an 
installation on the same computer, an Available licence is not removed 
from your account. 

NOTE: 
If Alt&Title does not have an Available licence, you will need to purchase 
one. 

Un-license 

If you no longer wish to use Alt&Title, or would like to use its associated 
licence on another computer, it can be un-licensed. 

In the Licensing dialog Online tab (Fig. 6) click the Un-license button. If 
successful, No is displayed in the Licensed column, and an Available 
licence for the associated plug-in is added to your user account. 

Manual Licensing 

If the computer where Alt&Title is installed does not have an Internet 
connection, it must be licensed manually. 

Manual licensing involves two processes: 

1. Request an Alt&Title licence from Fly Software; 

2. Activate the requested licence. 

Request Licence(s)  

The first part of the manual licensing process involves saving a licence 
request file then emailing it to Fly Software. 

The licence request file has the following filename: 

AltTitle Licence (user name – yyyymmddhhmmss).req 

This file contains information about Alt&Title together with your user 
name and password. 
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Select Help > Licensing to open the Licensing dialog. Now click the 
Manual (Request) tab to display the Licensing dialog Manual (Request) tab 
(Fig. 7). 

 

Fig. 7 Licensing dialog Manual (Request) tab 

To save a licence request file, perform the following: 

1. Specify your user name and password; 

2. Click (tick) the Alt&Title checkbox; 

3. Select where you would like to save the licence request file; 

4. Click the Save button; 

5. In the Confirmation dialog, click the OK button to close it. 

Email the licence request file to license@flysoftware.com. This process is 
likely to involve moving the file to a computer with an Internet 
connection. 

After receiving the licence request file, Fly Software uses it to create a 
corresponding licence activation file.  

mailto:license@flysoftware.com�
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Activate Licence  

The second part of the manual licensing process involves activating the 
requested Alt&Title licence. This is achieved using the licence activation 
file which is normally emailed to you by Fly Software within 24 hours of 
receiving your licence request file. 

The licence activation file has the following filename: 

AltTitle Licence (user name – yyyymmddhhmmss).req 

NOTE: 
If you do not have an Available Alt&Title licence in your Fly Software user 
account, you will be notified by email. A licence will need to be purchased 
and the associated licence requested again. 

NOTE: 
When you receive your licence activation file, save it, and if necessary, 
make it accessible to the computer where Alt&Title is installed. 

Select Help > Licensing to open the Licensing dialog. Now click the 
Manual (Activate) tab to display the Licensing dialog Manual (Activate) tab 
(Fig. 8). 

 

Fig. 8 Licensing dialog Manual (Activate) tab 
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To activate the requested Alt&Title licence, perform the following: 

1. Click the Browse button; 

2. In the Open dialog, locate and select your licence activation file 
then click the Open button to close the Open dialog; 

3. Click the Open button; 

4. Click the Activate button to activate the Alt&Title licence marked as 
Awaiting Activation. 

Un-license 

Please email license@flysoftware.com requesting instruction about how to 
manually un-license Alt&Title. 

mailto:license@flysoftware.com�
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Displaying Developer and Application 
Information 

Information about Fly Software, copyright notices and Alt&Title’s version 
number, can be viewed on the Welcome screen when the application is 
launched, or at any time in the About dialog (Fig. 9). 

 

Fig. 9 About dialog 

To display the About dialog, select Help > About Alt&Title. 

Click the OK button to close the About dialog. 
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Viewing Preferences 
Much of the functionality within Alt&Title is configured within the 
Preferences dialog (Fig. 10). 

 

Fig. 10 Preferences dialog 

To open the Preferences dialog select File > Preferences. 

If a change is made within the Preferences dialog, click the OK button to 
apply it, or the Cancel button to cancel it. Following this, the Preferences 
dialog is closed. 
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Using Panels 
The Folder panel, File panel, Log panel and References panel can all be 
resized, and the content they contain can be moved. 

Resizing 

The internal vertical and horizontal borders of panels are used for resizing.  

Move the mouse cursor over a border until it changes to a double arrow 
then click and hold the mouse button. Move the mouse left or right for a 
vertical border, or up and down for a horizontal border to resize the panel. 
When the panel is at your preferred size, release the mouse button. 

NOTE: 
Resizing a panel automatically resizes any adjacent panel. 

Moving Content 

Scrollbars appear when the content within a panel extends beyond its 
viewable area. 

Scrollbars are used to move the content of a panel left and right (for a 
horizontal scrollbar), or up and down (for a vertical scrollbar). 

MORE: 
For details about using scrollbars, refer to your Windows® documentation 
or Help. 
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Navigating Folders 
The Folder panel displays a list of folders and drives contained within your 
Windows® file system. It enables you to locate the files you want to scan or 
perform an add attribute process on. 

Click the plus (+) symbol next to a folder or drive icon to open it. 
Alternatively, double-click the folder or drive’s icon or name. Following 
this, folders it may contain are displayed below it. 

Click a folder icon or name to display the supported files it contains within 
the File panel. 

Click the minus (–) symbol next to a folder or drive icon to close it. 
Alternatively, double-click the folder or drive’s icon or name. 

NOTE: 
When launched, Alt&Title automatically opens the folder or drive that was 
previously open prior to shutting down. 
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Selecting Files 
Files you want to scan or perform an add attribute process on, must be 
selected within the File panel. 

NOTE: 
If a file you expect to see in the File panel is not displayed, its format may 
not be selected or specified in the Preferences dialog (Fig. 10). 

There are several ways to select files in the File panel: 

• To select an individual file, click its filename; 
• To select a consecutive group of files, click the filename of the first 

file, hold down the SHIFT key then click the filename of the last file. 
• To select a consecutive group of files without using the keyboard, 

drag the mouse pointer to create a selection around the outside of 
all the files you want to include then release the mouse button. 

• To select non-consecutive files, hold down the CTRL key then click 
the filename of each file you want to select. 

• To select all files, select File > Select All.  

NOTE: 
When the File panel is active, selected files have a blue background. When 
the File panel is inactive (i.e. the Folder panel is active), selected files have 
a grey background. 

Cancelling Selection 

There are several ways to cancel the selection of files in the File panel: 

• To cancel the selection of individual files within a selected group, 
hold down the CTRL key then click the filename of each file you no 
longer want to include. 

• To cancel the selection of all files, select File > Deselect All. 

Opening a File 

 Double-click a file in the File panel to open it within its native application. 

EXAMPLE: 
If an ASP file is associated with Dreamweaver, Dreamweaver is launched 
and the file is opened within it. 
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Updating 
Alt&Title is continually being developed. As a result, new versions will 
become available that introduce new features or improve existing ones. 

To avoid technical difficulties and to benefit from the latest 
enhancements, it is advised you update your Alt&Title installation 
regularly.  

NOTE: 
Prior to updating, it is advised you uninstall your existing installation of 
Alt&Title. 

Updating Alt&Title is performed in the same way as installing it. 
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Shutting Down 
Alt&Title is shutdown by selecting File > Exit, or by clicking the close (X) 
button located top-right of the Title bar.  
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Uninstalling 
If you no longer wish to use Alt&Title and would like to remove it from 
your computer, it can be uninstalled. 

NOTE: 
Before Alt&Title can be uninstalled, it must first be shutdown. 

Alt&Title is uninstalled using the Windows® Add/Remove Programs or 
Programs and Features facility within the Windows® Control Panel. 

MORE: 
For details about the Windows® Add/Remove Programs or Programs and 
Features facility, refer to your Windows® documentation or help. 
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Configuring 

In this section the following information is included: 

• File Formats 
• HTML Tags 
• Language Tags 
• References 
• Attribute 
• Dreamweaver Template Code 
• Backup Warning DialogBackup Warning Dialog 
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File Formats 
To ensure the File panel is only populated with specific files, or to display 
other non-default supported files, file formats can be selected, deselected 
and specified. 

Selecting 

To select a file format, open the Preferences dialog (Fig. 10) then click the 
checkbox next to a file format to add a tick.  

To select all file formats and tick all checkboxes, click the Select All button. 

Deselecting 

To deselect a file format, open the Preferences dialog (Fig. 10) then click 
the checkbox next to a file format to remove the tick. 

To deselect all file formats and remove the tick from all checkboxes, click 
the Deselect All button. 

Specifying 

To specify a file format, open the Preferences dialog (Fig. 10) and type the 
extension (i.e. txt) of the required file format in the Other text box. 

To specify more than one file format, separate each extension with a semi 
colon (;). 

EXAMPLE: 
txt;vbs;wml 
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HTML Tags 
By default, all supported HTML tags are scanned and have an add 
attribute process performed on them. However, if you do not want a 
particular HTML tag to be reported in the Log panel, or updated, it can be 
turned off. 

Select Tools > area, img or input (image) to remove the associated tick 
and ignore the HTML tag, or add a tick and enable the HTML tag. 
Alternatively, click an area, img or input (image) button on the Application 
toolbar to push it up and ignore the HTML tag, or push it down to enable 
the HTML tag. 
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Language Tags 
To enable Alt&Title to deal with language code such as ASP that may be 
embedded within supported HTML tags, it must know its opening and 
closing tags. 

EXAMPLE: 
ASP code opens with <% and closes with %>. 

The Preferences dialog (Fig. 10) provides a facility for adding, editing and 
deleting the opening and closing tags of languages present within the 
files you scan and perform add attribute processes on. 

By default, the opening and closing tags of the following languages are 
already defined: 

• ASP 
• JSP 
• PHP 

CAUTION: 
If opening and closing tags are not defined for language code that 
appears within HTML tags, unpredictable and undesirable results may 
occur during an add attribute process. 

Adding 

To add the opening and closing tags of a language, open the Preferences 
dialog (Fig. 10) then click the Add button within the Tags to Ignore 
section. Following this, an Add Tags to Ignore dialog (Fig. 11) appears 
where the opening and closing tags of a language can be defined. 

 

Fig. 11 Add Tags to Ignore dialog 

After specifying a language description together with its opening and 
closing tags, click the OK button to close the Add Tags to Ignore dialog 
and return to the Preferences dialog. 

To cancel the add process and return to the Preferences dialog, click the 
Cancel button. 
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Editing 

To edit the description, and opening and closing tags of a language, open 
the Preferences dialog (Fig. 10) then click the required language name 
followed by the Edit button within the Tags to Ignore section. Following 
this, an Edit Tags to Ignore dialog (Fig. 12) appears where the opening and 
closing tags of a language can be defined. 

 

Fig. 12 Edit Tags to Ignore dialog 

After making the required changes, click the OK button to close the Edit 
Tags to Ignore dialog and return to the Preferences dialog. 

To cancel the edit process and return to the Preferences dialog, click the 
Cancel button. 

Deleting 

To delete a previously defined language tag, open the Preferences dialog 
(Fig. 10) then click the required language name followed by the Delete 
button. Following this, a Confirm Delete Tag dialog (Fig. 13) is displayed. 

 

Fig. 13 Confirm Delete Tag dialog 

To delete the language tag and return to the Preferences dialog, click the 
Yes button. 

To cancel the delete and return to the Preferences dialog, click the No 
button. 
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References 
When a file is scanned, or has an add attribute process performed on it, a 
reference within a supported HTML tag such as an image filename or code 
that refers to an image filename, is listed in the References panel. 

EXAMPLE: 
The following HTML tag: 

<img src="iform_designer.gif" alt="iFORM Designer" /> 

Would cause the following reference (image filename) to be listed: 

iform_designer.gif 

Ignoring 

It is likely certain references would never need to be reported in the Log 
panel, or have an alt or title attribute added to them. 

EXAMPLE: 
A shim image (i.e. shim.gif) would not normally require an alt or title 
attribute. 

For this reason, references can be moved to the References Ignored panel 
so they are ignored for all future scans and add attribute processes. 

Select one or more references in the References panel then click the 
greater than (>) button to move the selection to the References Ignored 
panel.  

MORE: 
For details about the mechanism used to select references, refer to 
Getting Started > Selecting Files.  

NOTE: 
Selected references have a blue background. 

NOTE: 
References added to the references Ignored panel remain throughout 
Alt&Title sessions until they are removed.  

Removing Ignored References 

References must be removed from the References Ignored panel before 
they are considered again during future scans and add attribute 
processes. 
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Select one or more references in the References Ignored panel then 
perform one of the following actions: 

• Right-click anywhere within the selection, then click the Delete 
option on the Context menu; or 

• Click the less than (<) button to move the selection to the 
References panel. 

MORE: 
For details about the mechanism used to select references, refer to 
Getting Started > Selecting Files.  
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Attributes 
Options are provided to determine whether messages associated with alt 
and title attributes are displayed within the Log panel during a scan. This 
is useful for limiting the amount of information you see in the Log panel 
(i.e. you may only be interested in missing title attributes so alt attributes 
can be turned off). 

Select Log > Show Missing alt Attribute in Scan, or Show Missing title 
Attribute in Scan to remove the tick and turn the option off, or add a tick 
and turn the option on. 

NOTE: 
Turning off one of these options does not affect an add attribute process 
or the associated reporting in the Log panel. 
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Dreamweaver Template Code 
When a Dreamweaver template is updated using Dreamweaver, files that 
contain HTML code derived from that template are also updated. As such, 
it may be preferable for Alt&Title to ignore HTML code derived from a 
Dreamweaver template, so any alt and title attribute additions are not 
overwritten following a Dreamweaver template update. 

NOTE: 
It is advised the following process is performed when dealing with 
Dreamweaver template code: 

1. Perform an add attribute processes on a Dreamweaver template; 
2. Use Dreamweaver to update the files that contain HTML code 

derived from that template. 

An option is provided to determine whether HTML code derived from a 
Dreamweaver template is scanned and has an add attribute process 
performed on it. By default, this option is turned off, but can be turned on 
if required. 

Open the Preferences dialog (Fig. 10) then click the Scan/update code 
derived from a Dreamweaver template checkbox to add a tick and turn 
the option on, or remove the tick and turn the option off. 

Dreamweaver Template Code Detected Dialog 

To alert you that Dreamweaver template code will be updated, a 
Dreamweaver Template Code Detected dialog () can be displayed at the 
start of an add attribute process. 

 

Fig. 14 Dreamweaver Template Code Detected dialog 

By default, this dialog is turned on, but can be turned off if required. 

Open the Preferences dialog (Fig. 10) then click the Show Dreamweaver 
template code detected dialog checkbox to remove the tick and turn the 
dialog off, or add a tick and turn the dialog on.  
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Backup Warning Dialog 
To enable you to revert back to the condition files were in prior to an add 
attribute process being performed, it is advised they are backed up. 

As a reminder, a Backup Warning dialog (Fig. 15) can be displayed at the 
start of an add attribute process.  

 

Fig. 15 Backup Warning dialog 

By default, this dialog is turned on, but can be turned off if required. 

Open the Preferences dialog (Fig. 10) then click the Show Backup Warning 
dialog checkbox to remove the tick and turn the dialog off, or add a tick 
and turn the dialog on. 

MORE: 
For details about backing up files, refer to your Windows® documentation 
or Help. 
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File Operations  

In this section the following information is provided: 

• Scanning 
• Adding Attributes 
• Stopping a Scan or Add Attribute Process 
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Scanning 
Alt&Title allows you to scan one or more files and report which supported 
HTML tags have missing alt and title attributes. 

To perform a scan: 

1. Select one or more files in the File panel; 
2. Select Tools > Scan, or click the Scan button on the Application 

toolbar. 

Following this, scan messages are reported in the Log panel, and relevant 
references are listed in the References panel. 

MORE: 
For details about Log messages, refer to Appendix A – Log Messages. 

The Progress bar displays the progress of a scan.  

NOTE: 
If expected messages do not appear in the Log panel, one or more of the 
following may need addressing: 

• A supported tag is turned off; 
• An associated reference is being ignored; 
• Reporting of alt and/or title attributes is turned off; 
• Reporting of Dreamweaver template code is turned off. 
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Adding Attributes 
The core functionality of Alt&Title is to add missing alt and title attributes 
to supported HTML tags contained in one or more selected files. 

NOTE: 
During an add attribute process all changes made are reported in the Log 
panel. 

CAUTION: 
Adding alt and title attributes is permanent and cannot be undone. Prior 
to doing so, it is therefore advised you perform a backup of relevant web 
files and preview the changes that will be made. 

If enabled, a Backup Warning dialog (Fig. 15) is displayed prior to 
performing an add attribute process. 

If Dreamweaver template code will be updated, a Dreamweaver Template 
Code Detected dialog (Fig. 14) (if enabled) is displayed prior to performing 
an add attribute process. 

The Progress bar displays the progress of an add attribute process.  

NOTE: 
Until Alt&Title is licensed, an add attribute process can only be previewed, 
and no changes will be made to selected files.  

Alt Attribute 

To add an alt attribute to supported HTML tags that already contain a title 
attribute: 

1. Select one or more files in the File panel; 
2. Select Tools > Add alt, or click the Add alt button on the 

Application toolbar.  

Following this, the required changes are made (if Preview is turned off), 
add attribute messages are reported in the Log panel, and relevant 
references are listed in the References panel. 

MORE: 
For details about Log messages, refer to Appendix A – Log Messages. 

Title Attribute 

To add a title attribute to supported HTML tags that already contain an alt 
attribute:  

1. Select one or more files in the File panel; 
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2. Select Tools > Add title, or click the Add title button on the 
Application toolbar.  

Following this, the required changes are made (if Preview is turned off), 
add attribute messages are reported in the Log panel, and relevant 
references are listed in the References panel. 

MORE: 
For details about Log messages, refer to Appendix A – Log Messages. 

Previewing 

Prior to adding alt or title attributes, it is advised the changes that will be 
made are previewed in the Log panel.  

Select Tools > Preview to add a tick and enable previewing, or remove the 
tick and disable previewing. Alternatively, click the Preview toolbar button 
to push it down and enable previewing, or push it up and disable 
previewing. 

NOTE: 
Previewing is permanently enabled until Alt&Title is licensed. 
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Stopping a Scan or Add Attribute Process 
To stop a scan or an add attribute process, select Tools > Stop. 
Alternatively, click the Stop button on the Application toolbar. 
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Log Operations 

In this section the following information is provided: 

• Opening 
• Saving 
• Printing 
• Copying 
• Clearing 
• Determining Messages to Display 

MORE: 
For details about Log messages, refer to Appendix A – Log Messages. 
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Opening 
To open a log file:  

1. Click the Open Log button on the Log toolbar. Following this, a 
standard Windows® Open dialog is displayed; 

2. Browse the file system for the required Log file then select it; 
3. Click the Open button to close the Open dialog and display the 

messages the log file contains in the Log panel. 

NOTE: 
Messages contained in an opened log file are displayed after other 
messages already present in the Log panel.  

MORE: 
For details about using the Windows® Open dialog, refer to your 
Windows® documentation or Help. 
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Saving 
To save all messages contained in the Log panel to a Log file: 

1. Click the Save Log button on the Log toolbar. Following this, a 
standard Windows® Save dialog is displayed; 

2. Browse the file system to select a save location; 
3. Specify a filename for the Log file; 
4. Click the Save button to save it and close the Save dialog. 

MORE: 
For details about using the Windows® Save dialog, refer to your Windows® 
documentation or Help. 
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Printing 
To print all messages contained in the Log panel: 

1. Click the Print button on the Log toolbar. Following this, a standard 
Windows® Print dialog is displayed; 

2. Select a printer; 
3. Click the print button to print the messages and close the print 

dialog. 

MORE: 
For details about using the Windows® Print dialog, refer to your Windows® 
documentation or Help. 
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Copying 
To copy messages contained in the Log panel to the Windows® clipboard: 

1. Position the mouse pointer at the start of the Log panel content 
you want to copy; 

2. Click and hold the mouse button; 
3. Move the mouse until the content you want to copy is highlighted 

(with a black background); 
4. Release the mouse button; 
5. Click the Copy button on the Log toolbar, or right-click over the 

highlighted content then select the Copy to Clipboard option that 
appears. 
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Clearing 
To clear (remove) all the messages in the Log panel, click the Clear button 
on the Log toolbar. Following this, a Confirm Clear dialog (Fig. 16) is 
displayed asking you to confirm the clear. 

 

Fig. 16 Confirm Clear Log dialog 

Click the Yes button to close the Confirm Clear dialog and clear the 
messages in the Log panel. 

Click the No button to close the Confirm Clear dialog and cancel the clear. 
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Determining Messages to Display 
Messages that appear in the Log panel can be restricted in the following 
ways: 

• Ignore specific supported HTML tags; 
• Ignore specific references; 
• Ignore specific attributes; 
• Ignore code derived from a Dreamweaver template. 

MORE: 
For details about restricting messages in the Log panel, refer to 
Configuring.
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Technical Support and 
Troubleshooting 

In this section the following information is provided: 

• Staying Up-to-date 
• Finding Answers to Common Questions 
• Requesting Support 
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Staying Up-to-date 
One of the best ways to help ensure your experience with Alt&Title is as 
problem-free as possible is to keep your installation up-to-date.  

MORE: 
For further details about updating Alt&Title, refer to Getting Started > 
Updating.  
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Finding Answers to Common Questions 
A Knowledge Base, where solutions to common Alt&Title questions are 
provided, can be found on the following Fly Software web page: 

http://www.flysoftware.com/support/knowledge_base.asp 

NOTE: 
If you encounter a problem, please refer to the Knowledge Base for a 
solution before requesting support from Fly Software. 

http://www.flysoftware.com/support/knowledge_base.asp�
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Requesting Support 
Fly Software operate a support ticket system for anyone who encounters a 
problem using Alt&Title.  

NOTE: 
If you encounter a problem, please consult the Knowledge Base for a 
solution before submitting a support ticket. 

Support tickets can be submitted, and previous tickets and associated 
responses viewed, on the following Fly Software web page: 

http://www.flysoftware.com/user_account/support_form.asp 

NOTE: 
To submit or view support tickets, you must login or sign-up for a Fly 
Software User Account. 

http://www.flysoftware.com/user_account/support_form.asp�
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Appendix A -  
Log Messages 

Log Message Description 

alt & title missing - unable to 
add alt 

Indicates an alt attribute could not be 
added to the associated HTML tag 
because a title attribute was not 
present. 

alt & title missing - unable to 
add title 

Indicates an alt attribute could not be 
added to the associated HTML tag 
because an alt attribute was not 
present. 

alt added: "x" Indicates the alt attribute added to the 
associated HTML tag. 

n alt attribute(s) added Indicates the number of alt attributes 
added to the selected file(s). 

n alt attribute(s) would be 
added 

Indicates the number of alt attributes 
that would be added to the selected 
file(s). 

alt missing Indicates an alt attribute is missing from 
the associated HTML tag. 

alt would be added: "x" Indicates the alt attribute that will be 
added to the associated HTML tag. 

Detected code derived from 
a Dreamweaver Template 

Indicates the associated file contains 
code derived from a Dreamweaver 
template. 

Dreamweaver Template End Indicates the end of Dreamweaver 
template code. 

Dreamweaver Template Start Indicates the start of Dreamweaver 
template code. 

Line n 
Indicates the line number within the 
associated file where a missing alt or 
title attribute is located. 
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Log Message Description 

Missing alt attributes: n Indicates the total number of missing alt 
attributes within the selected file(s). 

Missing title attributes: n Indicates the total number of missing 
title attributes within the selected file(s). 

No Changes Indicates missing alt and title attributes 
were not found in the associated file. 

Path Indicates the drive and folder path of 
the selected file(s). 

Process ended dd/mm/yyyy 
hh:mm:ss 

Indicates the date and time a scan or 
add process ended. 

Process started dd/mm/yyyy 
hh:mm:ss 

Indicates the date and time a scan or 
add process started. 

title added: "x" Indicates the title attribute added to the 
associated HTML tag. 

n title attribute(s) added Indicates the number of title attributes 
added to the selected file(s). 

n title attributes would be 
added 

Indicates the number of title attributes 
that would be added to the selected 
file(s). 

title missing Indicates a title attribute is missing from 
the associated HTML tag. 

title would be added: "x" Indicates the title attribute that will be 
added to the associated HTML tag. 

Updated successfully 
Indicates the associated file was 
updated successfully during an add 
attribute process. 



 

Alt&Title User Guide 59 

Index 

A 
About dialog ............................................................................ 20 
About this user guide and help .......................................... iv 
Activate licence ....................................................................... 18 
Add 

Language tags .................................................................... 32 
Adding attributes ................................................................... 41 
Alt attribute .............................................................................. 41 
Alt&Title Icon ........................................................................... 11 
App.ini ........................................................................................... 9 
Appendix A - Log messages .............................................. 57 
Application 

Information .......................................................................... 20 
Menus .................................................................................... 12 
Toolbar .................................................................................. 12 
Window ................................................................................. 12 

area HTML tag ............................................................................ 8 
Attributes 

Adding ................................................................................... 41 
Alt ............................................................................................ 41 
Configuring ......................................................................... 36 
Title ......................................................................................... 41 

B 
Backup files ............................................................................... 38 
Backup warning ...................................................................... 38 
Bar 

Progress .................................................................. 12, 40, 41 
Status ..................................................................................... 13 
Title ......................................................................................... 12 

C 
Cancel 

File selection ....................................................................... 24 
Clear log messages ................................................................ 50 
Configure 

Attributes ............................................................................. 36 
Dreamweaver template code....................................... 37 
File formats .......................................................................... 30 
HTML tags ............................................................................ 31 
Language tags .................................................................... 32 
References............................................................................ 34 

Configuring .............................................................................. 29 
Contents ..................................................................................... vii 

At a glance ...........................................................................viii 
Concise .................................................................................... ix 

Copy log messages................................................................ 49 

D 
Delete 

Language tags .................................................................... 33 
Deselect 

File formats .......................................................................... 30 
Determining log messages to display ........................... 51 
Developer information ........................................................ 20 
Dialog 

About ..................................................................................... 20 
Add Tags to Ignore ........................................................... 32 
Backup Warning ................................................................ 38 
Confirm Clear Log ............................................................. 50 
Confirm Delete Tag .......................................................... 33 
Dreamweaver Template Code Detected ................. 37 
Edit Tags to Ignore ............................................................ 33 
Licensing Manual (Activate) tab .................................. 18 
Licensing Manual (Request) tab .................................. 17 
Licensing Online tab ........................................................ 15 
Preferences .......................................................................... 21 

Dreamweaver template code ........................................... 37 

E 
Edit 

Language tags .................................................................... 33 
Exit ............................................................................................... 26 

F 
Fig. 

About dialog ....................................................................... 20 
Add Tags to Ignore dialog ............................................. 32 
Adding attributes ................................................................. 3 
Alt&Title icon ....................................................................... 11 
Confirm Clear Log dialog ............................................... 50 
Confirm Delete Tag dialog ............................................ 33 
Dreamweaver Template Code Detected dialog ... 37 
Edit Tags to Ignore dialog .............................................. 33 
Licensing dialog Manual (Activate) tab .................... 18 
Licensing dialog Manual (Request) tab .................... 17 
Licensing dialog Online tab .......................................... 15 
Locating and reporting missing alt and title 

attributes ............................................................................ 3 
Preferences dialog ............................................................ 21 
Warning Backup dialog................................................... 38 

File 
Backup ................................................................................... 38 
Cancel file selection.......................................................... 24 
Open ....................................................................................... 24 
Operations ........................................................................... 39 



Index 

60 Alt&Title User Guide 

Selecting ............................................................................... 24 
File formats 

Configuring ......................................................................... 30 
Deselecting .......................................................................... 30 
Selecting ............................................................................... 30 
Specifying ............................................................................ 30 
Supported ............................................................................... 7 

File operations ........................................................................ 39 
File panel ................................................................................... 12 
Folder panel ............................................................................. 12 
Folders ........................................................................................ 23 
Foreword ..................................................................................... iii 
Frequently Asked Questions ............................................. 55 

G 
Getting started ........................................................................... 5 

H 
HTML tags 

Configuring ......................................................................... 31 
Supported ............................................................................... 8 

I 
Icon 

Alt&Title ................................................................................ 11 
Ignoring references ............................................................... 34 
img HTML tag ............................................................................. 8 
input (image) HTML tag ......................................................... 8 
Install.............................................................................................. 9 

Application data ................................................................... 9 
Application files .................................................................... 9 
Location (default) ................................................................. 9 

Introduction ................................................................................ 1 

K 
Knowledge Base ..................................................................... 55 

L 
Language tags 

Adding ................................................................................... 32 
Configuring ......................................................................... 32 
Deleting ................................................................................ 33 
Editing ................................................................................... 33 

Launching ................................................................................. 11 
Licence 

Purchase ............................................................................... 14 
Licence activation file ........................................................... 18 
Licence request file ............................................................... 16 
License 

Manually ............................................................................... 16 
Online ............................................................................. 14, 16 

License.ifl ...................................................................................... 9 
Licensing ................................................................................... 14 
Licensing dialog Manual (Activate) tab ......................... 18 
Licensing dialog Manual (Request) tab ......................... 17 
Licensing dialog Online tab ............................................... 15 
Log 

Toolbar .............................................................................. 7, 12 
Log file 

Open ...................................................................................... 46 
Save ........................................................................................ 47 

Log messages .......................................................................... 57 
Clearing ................................................................................. 50 
Copying ................................................................................. 49 
Displaying ............................................................................ 51 
Opening ................................................................................ 46 
Printing.................................................................................. 48 
Saving .................................................................................... 47 

Log operations ........................................................................ 45 
Log panel .................................................................................. 12 

M 
Manual licensing .................................................................... 16 

Activate ................................................................................. 18 
Request ................................................................................. 16 

Menus ......................................................................................... 12 
Moving panel content.......................................................... 22 

N 
Navigating folders ................................................................. 23 

O 
Online 

License ................................................................................... 16 
Licensing .............................................................................. 14 
Un-license ............................................................................ 16 

Open 
File ........................................................................................... 24 

Open log file............................................................................. 46 
Open log messages ............................................................... 46 

P 
Panel 

File ........................................................................................... 12 
Folder ..................................................................................... 12 
Log .......................................................................................... 12 
References ........................................................................... 12 
References ignored .......................................................... 12 

Panels ......................................................................................... 22 
Moving content ................................................................. 22 
Resizing ................................................................................. 22 

Preferences ............................................................................... 21 
Previewing ................................................................................ 42 
Print log messages ................................................................ 48 
Printing 

User guide and help ........................................................... iv 
Progress bar ............................................................... 12, 40, 41 
Purchasing a licence ............................................................. 14 

R 
References 

Configuring ......................................................................... 34 
Ignoring ................................................................................ 34 
Removing ignored ............................................................ 34 



Index 

Alt&Title User Guide 61 

References ignored panel ................................................... 12 
References panel .................................................................... 12 
Removing ignored references .......................................... 34 
Request licence ....................................................................... 16 
Requesting support .............................................................. 56 
Resize 

Panels ..................................................................................... 22 
Running ..................................................................................... 11 

S 
Save log file .............................................................................. 47 
Save log messages ................................................................. 47 
Scanning .................................................................................... 40 
Select 

File formats .......................................................................... 30 
Files ......................................................................................... 24 

Shutting down ........................................................................ 26 
Side headings ............................................................................ vi 
Specify 

File formats .......................................................................... 30 
Status bar .................................................................................. 13 
Staying up-to-date ................................................................ 54 
Stopping a Scan or Add Attribute Process ................... 43 
Support ...................................................................................... 56 
Support ticket .......................................................................... 56 
Supported 

File formats ............................................................................. 7 
HTML tags ............................................................................... 8 

System requirements .............................................................. 6 

T 
Technical support .................................................................. 53 
Terminology ................................................................................ v 
Title attribute ........................................................................... 41 
Title bar ...................................................................................... 12 
Toolbar 

Application .......................................................................... 12 
Log ...................................................................................... 7, 12 

Troubleshooting ..................................................................... 53 

U 
Uninstalling .............................................................................. 27 
Un-license 

Manually ............................................................................... 19 
Online .................................................................................... 16 

Updating.................................................................................... 25 
User account ............................................................................ 15 

V 
View 

Preferences .......................................................................... 21 

W 
What Alt&Title can do for you .............................................. 3 
Why you need Alt&Title .......................................................... 2 
Workspace ................................................................................ 12 

 


	Cover 
	Masthead

	Foreword
	About this User Guide and Help
	Printing

	Terminology
	Side Headings
	Contents
	At a Glance
	Concise



	Contents

	At a Glance
	Concise

	Introduction
	Why You Need Alt&Title
	What Alt&Title can do for You

	Getting Started
	System Requirements
	Supported File Formats
	Supported HTML Tags
	Installing
	Default Install Locations
	Application Files
	Application Data


	Launching
	Workspace Overview
	Licensing
	Purchasing a Licence
	Online Licensing
	Connecting to Your Fly Software User Account
	License
	Un-license

	Manual Licensing
	Request Licence(s)
	Activate Licence
	Un-license


	Displaying Developer and Application Information
	Viewing Preferences
	Using Panels
	Resizing
	Moving Content

	Navigating Folders
	Selecting Files
	Cancelling Selection
	Opening a File

	Updating
	Shutting Down
	Uninstalling

	Configuring
	File Formats
	Selecting
	Deselecting
	Specifying

	HTML Tags
	Language Tags
	Adding
	Editing
	Deleting

	References
	Ignoring
	Removing Ignored References

	Attributes
	Dreamweaver Template Code
	Dreamweaver Template Code Detected Dialog

	Backup Warning Dialog

	File Operations
	Scanning
	Adding Attributes
	Alt Attribute
	Title Attribute
	Previewing

	Stopping a Scan or Add Attribute Process

	Log Operations
	Opening
	Saving
	Printing
	Copying
	Clearing
	Determining Messages to Display

	Technical Support and Troubleshooting
	Staying Up-to-date
	Finding Answers to Common Questions
	Requesting Support

	Appendix A -  Log Messages
	Index

